Pasted part will not constrain


I’m new to FreeCAD and am looking for guidance on how to proceed.

I purchased some plans to make some gears. Since I don’t want to make all the gears (not yet), I’m working on a single gear to get an understanding on how the software works.

The original plans are in dxf format (no idea if that makes a difference) but was able to open it into FreeCAD. I selected my gear using shift-B to copied and pasted into a new drawing. My problem is when I try to attach it to a plane or constrain the gear to extrude, it doesn’t work.

I have attached the gear drawing.

I would appreciate any assistance.



gear.FCStd (16.3 KB)

The main issue is that you only have shapes. The secondary issue is that the main shape is the gear with teeth and a circle.

Rule 1 in FreeCAD is that you can only pad/pocket a sketch, when you can do the same on paper when cutting all lines. The first shape will result in a very broken gear when cutting along all lines.

So lets fix this:

Enter “Part Design” workbench.

Due to the circle this is not possible to extrude the shape, but it is fixable. You need to utilize the SubShapeBinder feature to create a selection without the circle. Select the first shape on the left side. Now select all but the circle using the CTRL key. There is a way to use select all and then just deselect the circle, but I cannot remember the qualifier/hotkey or general way.

Once you selected the gear shape without the circle, click on the “SubShapeBinder” (the green splash shaped icon) function. It will add a body (ask for it) and a binder. Select the binder and now you can extrude the basic gear shape.

At this time you may notice that your dxf imports are way out of scale. The imported gear size is tiny and extruding 10mm creates a gigantic tower. :smiley:

Repeat the same with the other shapes (axle hole) using pocket.

I hope this helps.

BTW: AFAIR there is a gear generator available in FreeCADs addon manager.

Thanks Geit!

I got everything to work and even extruded the part. Like you said, extruding the part 10mm make it huge gear tower!

Can I ask you about scale? I need to open the original and see how big the gear is but it’s about 3" in diameter. I was playing with the units in the preferences, but that didn’t seem to make any difference. I also put it into draft or drawing mode and played with the custom scale ratio at the bottom, all with no success.


Glad you got it to work.

Unfortunately I never had that issue. The default unit of FreeCAD is mm (metric just like in slicers) and I guess your file got saved in inches(?). You could check the settings if there is a specific config for the file import. FreeCAD has overall settings for projects and import/export if the importer/exporter of the file format supports this. Maybe changing the entire application to inches is possible, but I don’t this this would be wise. FreeCAD is mostly used metric and therefor probably not well tested in imperial mode. (Just a guess) Another way would be to convert the original files or export them differently. Could also be that the file format has no flag for imperial/metric define or it was set wrong. No clue about the dxf format, so just speculation Sorry.

Metric FTW! :smiley:

It is quite a common issue. Even on thingiverse are ton of files. Some are even on factor 1000 to small. :smiley: No clue how this happens, but somehow it seems applications are able to mix up the and the dimension.

I did play with the gear creator and it worked well.

As for Metric, I’m from US, and we only know imperial.

I appreciate your assistance!


I’m in the US too and I found it much easier to design in Freecad using metric. If I’m measuring something I just measure in metric, it the dimensions are imperial I go online and use one of the many converters.

Like the maid said “I don’t do Windows”