Octoprint/Octopi 64 bit???

Can anyone give me a link to download Octopi 64 bit? Failing that, how about Octoprint 64 bit. I find it frustrating that it’s not readily apparent which version I’m getting. Also, how can I check to see what version I have after installation?

I think I’m missing something, perhaps because I run OctoPrint only on Rasberry Pi’s. Octoprint is written in Python, so are you looking for a 64-bit compatible version of the interpreter? Here is the download page at python.org: Download Python | Python.org


Octopi, as I understand it, is a complete package: OS + Octoprint. I have a RasPi 3B+ running it. It has been discussed on many forums how it has always been 32 bit and is not compatible with 64 bit, including not compatible with the RasPi 4B 8GB. I’ve been led to believe that that has changed and there is now a 64 bit version. I would like to look at it but can’t find a definitive source, so I thought I’d ask the resident experts.

Ok, now I understand. I thought you were running on a tablet or something. As my 4 has only 2 Gb, I haven’t worried about that issue. All official releases are 32-bit. You could try one of the “highly experimental” 64-bit builds:



LOL, I found that link a little while ago and downloaded the most recent: 2021-10-26_octopi-21.04-preinstalled-server-arm64+raspi-1.0.0.zip. It’s burning to a 32GB uSD as I type this.

How did it go? I forgot to mention that there is a plugin called “Resource Monitor” that will show how much memory there is. So, if you see 8 Gb, the OS is 64-bit.


Listen, thanks very much for the hint about Resource Monitor. I had been wondering how I can check whether I’m running 64 bit or not.

Ran into a problem: when I tried to install that plug-in, I got a message that PIP is not installed. Trying to resolve that.

I do have to say that I am not using an OctoPi image. I wanted to go the long route, to see what all is involved in getting Raspberry OS installed and set up, followed by OctoPrint. I even resolved an issue after I followed best practices and created a new user/password, then deleted the user “pi”. When I tried to get OctoPrint to auto-start, it failed. After some searching around, I realized that I needed to modify octoprint.service to use the new ID instead of “pi”.