Extruder running backwards at start of print

When I start a print my extruder pulls the filament back up the tube. I have to manually push it back down the tube to the nozzle. I have a ender3 v2 with latest Smith 3D BLTouch software and use Cura.
What have I got set wrong? Can some one help? thanks

You omitted 1 important item: after you manually push the filament down, does it then feed properly & print?

Yes it does

In that case I would inspect the Start G-code in Cura. I suspect there is a line in there that reads something like “G1 E-xxx…”. That would tell the extruder to retract.

Make sure you have the right start g-code set in Cura. Typically, the end g-code will do a slight retraction (a few mm). (You printer prints ok after you push the filament back down the tube?)


There is a: E0 ;Reset Extruder
And: G92 E0 ;Reset Extruder

I don’t think E0 by itself is valid. The G92 E0 is OK AFAIK. I would comment out the E0 line & test.

I will try that, thanks

My problem is solved. Thanks for your help Ender5r & Alan.
In Cura there is no choice for the Ender 3 V2 and I chose “Ender-3/EnderPro/Ender-3-3S”
I changed to “Creality Ender-3 Pro” and it seems to be working fine.
The key was the “E0” code tip from Ender5r. It’s in the “Ender-3/EnderPro/Ender-3-3S” Choice,
and not in the “Creality Ender-3 Pro” choice.
Thanks again

Are you saying that if you select Ender-3/EnderPro/Ender-3-3S as the printer, the Start G code has a line with only E0 in it? That really seems like a mistake. I just checked the list of valid commands on [U]https://marlinfw.org/meta/gcode/[/U] & I cannot find any command that starts with E (all the commands start with G or M).

It would be very interesting for you to go back & choose Ender-3/EnderPro/Ender-3-3S again, remove the E0 line, then test again. If the printer still works, you may have found a bug in your version of Cura. BTW, what version of Cura are you using?

Another way to think of it may be to blame, or partly blame, the Smith3D firmware, or perhaps Marlin in general. Properly written software should reject invalid commands (i.e. skip over them or stop & spit out an error message).

Probably something got accidentally deleted. There is a “G92 E0” command at the beginning.


My 4.8 (Mac) does not have a "Ender-3/EnderPro/Ender-3-3S" entry under add printers. The first two are listed (no “-3S” listing) and look identical and start with:

Ender 3 Pro
; Ender 3 Custom Start G-code
G92 E0 ; Reset Extruder
G28 ; Home all axes

Ender 3
; Ender 3 Custom Start G-code
G92 E0 ; Reset Extruder
G28 ; Home all axes


Looking at the screenshot, I can’t help wondering if the line that starts with “E0” is actually a continuation of the previous line. I think it’s unlikely, given that the line above seems to continue & normally lines of code are not allowed to wrap around, but I still think it’s a question.

If the E0 line is not part of the previous line, then it is truly strange, and I think it qualifies as a bug.

It would be nice if you could enlarge the machine settings window to show all codes at once. I scrolled over, doesn’t seem to be a continuation. It’s working well with the Creality Ender-3 Pro choice, so I will go from there. Someone smarter than me could inform Cura. Thanks

The easiest way to see all the codes (& to build your own or make changes) is to click in the window to put the cursor in the window, hit Ctrl-A to Select All, the Ctrl-C to copy to the Clipboard, then open Notepad & paste the contents.