Question For Micro Swiss Hardened Steel Nozzle Owners

I’ve been having an issue with the steel nozzle I just installed a week or so ago: it keeps unscrewing itself, leading to invalid Z Offset values. Last time, I used a socket wrench and an adjustable smooth jaw wrench to hold the heater block still while I torqued the nozzle as much as I dare.

Anyone else had this issue? Is it the steel nozzle in particular that’s an issue? Any suggestions on how to fix it? Do I dare use Locktite? I’m a little afraid to do that.

I have not used the Micro Swiss steel nozzles, so I cannot say for sure, but your issue appears to be either slightly different sized threads, or differential expansion of the 2 metals when heated. A small drop of Loctite blue 242 on the threads might cure the problem - not sure how it reacts to high heat. Loctite red requires heat to loosen, so that would not be appropriate.

EDIT: checked both the safety data sheet and technical data sheet for Loctite blue 242. There does not appear to be any issue using it so long as it is ONLY on the threads - it will cause problems if if contacts thermoplastics (filament). Also allow at least 12 hours for it to cure BEFORE using the printer.

I’m hoping I found the problem. This is what I found when I disassembled the hotend.


yeahhhhhh, quite the mess. As I was disassembling the hotend, I noticed that the heater block could be rotated easily by hand. That just didn’t seem right. I found that the heat break was loose in both the heater block and the cooling block, which explains how all that red and white filament oozed out onto the heater block. An hour of cleaning a 230C heater block (ouch!) and tightening everything up again, then recalibrating everything, and I’m hoping it will all work as well as it did after I 1st installed it. Fingers X’d.

@Ender5r, just wanted to check; do you tighten up the nozzle at high temperature? I’ve had good luck heating the block up to 240C before tightening the nozzle, and I always check the grub screws at temperature now, too, since I found them really loose when heated one time. I must have tightened them cold originally.
Sounds like you’re an old hand, hope this isn’t a bother.

An old hand? Not sure about that. I made my 1st print in June of 2020. But, yes, I did tighten up while hot. This time, I tightened up just a little more. And, I will check regularly to see if the heater block is moveable.

Had the issue again today. This time, only the heat break loosened up; the nozzle seemed fine. While cleaning up the gook from the top of the heater block I found that the heat break has 2 flat spots right at the spot where it should finish up tightening into the heater block, obviously for a wrench to fit (the 1 that came with the hotend). After heating to 230C I used that wrench to tighten up as much as I dare. Got my fingers X’d… again.

This issue keeps recurring. I finally called Micro Swiss. Almost unbelievably, the Help Desk guy called 1 of the engineers to the phone. I confirmed to him that I’m doing almost everything they recommend, including tightening up while hot. The 1 thing he mentioned, as a last resort, is to heat the hotend and then try tightening the nozzle and heat break at the same time. This is what I want to pass on to others: rather than gripping the heater block with pliers or Vise Grips and tighten the nozzle and heat break into the heater block separately, put wrenches on the nozzle and heat break and tighten them against each other (with nothing holding the heater block. I don’t know if this will work, but I’ll report back.

In the meantime, here’s a few photos of the latest leak disaster:

[ATTACH=JSON]{“data-align”:“none”,“data-size”:“medium”,“data-attachmentid”:13345}[/ATTACH] [ATTACH=JSON]{“data-align”:“none”,“data-size”:“medium”,“data-attachmentid”:13341}[/ATTACH] [ATTACH=JSON]{“data-align”:“none”,“data-size”:“medium”,“data-attachmentid”:13344}[/ATTACH]
[ATTACH=JSON]{“data-align”:“none”,“data-size”:“medium”,“data-attachmentid”:13342}[/ATTACH] [ATTACH=JSON]{“data-align”:“none”,“data-size”:“medium”,“data-attachmentid”:13343}[/ATTACH]

I’m really surprised about the troubles you are having, given MicroSwiss’ street reputation. (Kudos to the Help Desk support.) Could you have a defective part (happens to the best manufacturers), like a part the is slightly too small in one dimensions?


The tech guy did suggest that, if it continues, they might have to replace the heater block.

OK, I don’t want to speak too soon, but I might have, maybe, hopefully, found a solution to the oozing, and anyone who’s done plumbing will find it familiar. That’s right, I wrapped plumber’s teflon tape around the threads of both the heatbreak and the nozzle. Unlike typical plumbing, however, I could not wrap 3 or 4 or 5 windings of tape around the threads. I was able to get just over 1 layer around the threads. So far, no leaks. Got my fingers crossed it continues.

Can teflon tape stand that much heat? Typical hot water pipe is 120F or there about. Any I hope it works.

Teflon tape is good to 260C. Think about it; it’s used on fry pans :wink:

They use teflon on frying pans, tape is different, look up the specs on it

That’s where I got the 260C. I looked up “teflon tape max temp”.

Interesting experiment! It sounds like the steel nozzle is slightly out of spec. Who made it?


P.S. – Per Wikipedia: “PTFE (tape) is completely stable up to +260˚C”

The steel nozzle is a genuine Micro Swiss. I ordered it with the extruder-hotend combo. And, yes, a number of sources seem to agree on the max temp for teflon tape.

The teflon tape has helped, but not enough. I’m getting some ooz out of the joint between the heat break and the heat block, so I’ve ordered replacements for both of them.

Were you able to solve this puzzle?


I got the replacement heat break and heater block and installed them. I was very careful to ensure they got tightened up cleanly. I heated them to 260C after threading the heat break, heater block, and nozzle together by hand. Then I used wrenches to cinch them up tight.

But, before that, I inspected them carefully. I found a stray aluminum flake on the heater block, beside the hole where the heat break threads in. Got rid of that of course.

When I tried to thread the nozzle in, I found that it would go in part way, then get stiff. I did not like that. I got a magnifying glass and examined the nozzle threads closely. Near the tip of the threads I noticed the start of the initial turn of the thread was bent over slightly into the thread valley. I took a small pocket knife blade and used it to ‘flick’ the bent piece of thread back into place. I didn’t really care if if bent up or broke off completely, as long as it was no longer blocking the valley. It worked, because the nozzle threaded in much easier after fixing the thread. I was surprised by this. It’s a hardened steel nozzle. I find it difficult to believe that threading hardened steel into aluminum could bend a steel thread. More likely, the thread in the aluminum would get damaged. I suspect a manufacturing defect. I also suspect that that bad thread caused the problems with the initial heat break and heater block.

So far, I have not seen any oozing out from the joint between the nozzle and heater block, but it’s only been a few days. I have yet to remove the fan shroud to check the top of the heater block, but that’s coming soon.

Sound like you might have it under control. I have to agree I can’t see aluminum would bend the threads over on the still nozzle.