My new JG Maker Artist-D (pro)

I wouldn’t think so. Just to be sure, when you enter T0 or T1 into the terminal input box, you should get a response about which extruder is now active. Does that happen?

The only time I get a response is from the response M503.
The printer locked up on another build last night and I had to turn it off, When I did, it would not reconnect to the computer.
I shut the computer down last night and rebooted. I checked the task manager after waiting for a reasonable time and it said I had 25 instantiates of Avast running. Guess I will drop Avast.
After I get through a few chores I will try to link the printer to the computer, if you know the command to turn echo on in pronterface please tell me.

Yeah, blow away Avast. After they made improvements a few years ago, I now go with MicroSoft’s Defender (or whatever it’s called now).

If you type “T0” into the terminal input box, do you get anything in response? I get:

>>> t0
[ERROR] Printer is not online.

This is, as the response indicates, without even being connected to a printer. I don’t even have a cable plugged in.

I get that when computer is not connected, but when connected nothing it only says sending, other than from M503
I did get connected now.

I just connected my Surface Pro to my Artist D Pro and got the following after connecting to it on COM3 at 115,200 BAUD:

Printer is now online.
>>> t0
echo:Active Extruder: 0
>>> t1
echo:Active Extruder: 1
>>> t0
echo:Active Extruder: 0

If you don’t get the same results I’m not sure why. Here are a couple of captures of the Settings >> Options

[ATTACH=JSON]{“data-align”:“none”,“data-size”:“custom”,“height”:“296”,“width”:“386”,“data-attachmentid”:11830}[/ATTACH] [ATTACH=JSON]{“data-align”:“none”,“data-size”:“custom”,“height”:“296”,“width”:“385”,“data-attachmentid”:11831}[/ATTACH]

The firmware on my machine is V What version of firmware are you running. I read somewhere that the version 2.3.2 is out but it cuts the bed and hot end temperature to 60 and 250. I have copied all image data as you have except for yours is for a different printer. I still do not get it to echo, but I do see the Tool I am on, on the extreme left before the Extruder button. I, at first, only had 1 extruder listed. I am wondering if you have a later version of firmware and it has a register for both tool storage. where, mine does not. I want to gain features, not loose features, like bed and hot tend temperatures.

I will check the FW version, but I can tell you I’ve been able to use Pronterface on all the versions I’ve tried.

UPDATE: I’m running Robin 2.3.3

I sent JG Maker an email asking them if it had a regester for each hot end or just one, because I could not get mine to show but one register. I also told them what my version was, and I would not update the firmware with the lower hot end and bed. By the way I said it wrong, the bed is 100.
Today I had a friend come by who had not seen the printer and I attempted to show him how it printed. It went all ape with me. I told it a print that had successfully printed and the wrong nozzle wanted to move and acted like it was printing, but without heating either the bed or the nozzle. I cycled the power 3 time and it did not change. When I get a chance I will place a new file on sd card and try again.

I updated to the 2.3.3 version yesterday and it still does not echo.and there is only one register for both T0 and T1. I have been playing with upping the extruder and flow rates, because I am having adhesion and filament problems on first layers. I will post pictures on another post. Got other problems, a death in family.

I should have asked earlier, but what do you mean by “register”?

Sorry to hear about your loss. We just had 1 in our family. However, they were 91, so it’s not quite as upsetting as it would be otherwise.

Thanks, she was a couple of years older, and I understand she must have known because her husband said she just bought a vault at mosellem and made arrangements at a funeral home. Who knows!
I teal you, I am at a loss, the more I up the extruder valuers and or the flow rate the less the nozzle passes on to the bed. I got way out of proportions and it just got worse. I was doing both heads in dual mode and both got worse. I finally got fed up and did a factory reset. I got the best one layer 2 1/2 in square. today. You could see through it around the edges, so I increased the flow 5 units and it sealed the holes around the sides but created a group of 4 lines with about 3 or 4 lines between. I am going to slow the print down about 5 and see.
When I say registers that is a term for temporary machine language cpu storage. I was using that to mean storage for T0 and T1 information like the M92 E value for each, which I am only getting one value for both. Pronterface is showing under the bed temperature which one is active.

Ah. Just so you know, I wrote my 1st professional computer program in 1965, so the concept of registers is quite familiar, as is assembler and machine language coding.

I don’t think ‘registers’ really applies here though, hence my confusion. The values are stored in firmware, so it’s equivalent to writing to disk. I am going to double check my Artist D to verify that there are separate values, but my recollection is that there are.

OK, I just checked and I can confirm your findings. At least in Pronterface, whenever I change the E-steps for 1 extruder, I get the same value when I check the other extruder. Also, when I check the menu system, I can find only 1 setting for extruder E-steps.

I went a step further and checked firmware versions and 2.3.3. They both exhibit the same behavior.

This is a little disturbing. I’m not sure what can be done about it, except perhaps to use Extrusion Multiplier/Flow Rate to compensate.

@irvshapiro1, can you chime in here. Perhaps you can confirm or refute our findings and/or offer some other options for resolving the problem.

I was working on the third single layer, and it looked the best I had done, really close to what I wanted, when I ran out of filament, I took a long break while trying to decided which color to use. I decided to use a color close to what I had. This was called sapphire blue. It had a mat finish, but gave the closest to perfect first layer I have seen. I rejoiced a little and started printing some complete stacking storage trays the first layer came from. I was really pleased with the looks, with no stringing, layer lines, or ghosting. I did some duel head prints until one broke from the table on the other E1 side. This was also from the original filament that came with the printer. I then stretched the pattern and printed a single from E2. I even sliced for the other printer and printed to compare. I then did some jars with lids. They turned out good also. Now not to waste calibrate the single layer on E1. I am betting that this filament is not that good either and probably should discard and move on.
Please keep me informed on what you find out about the two M92 values situation.

Sounds like you’re making good progress. Congrats. As I said, I’m thinking, at least until we learn differently, we may need to use Flow Rate/Extrusion Multiplier to compensate for differences between E1 and E2 extrusion rates. This is where the 1-layer calibration squares really come into play, at least for me.

I agree, only I was using larger one layer to test. I, being satisfied, started working on the alignment color squares in Cura list of calibration models. After printing two layers each on 10 starts, I finally got to a place that seemed as close as I could get. I was down yo the tent of a number. The Y axis may be off, I didn’t play with that,.
Today I started to print another little storage bin a little longer than the others. Even with this new filament that I thought was so great, the first layer bubbled in the middle and each pass would lay it down but at finish it looked like the ocean. I let the second layer print and it improved the looks, but that is not what I wanted. I have played with temperature, on nozzle and bed, but that has not helped. Do you think that the filament has picked up moisture, and this is the by product of that, or do you have another suggestion,
Another question, I have seen these storage boxes on Amazon, do they work, or do I just put in a sealed bag for same results.

Do you have photos of this bubbling? I can’t help wondering if, maybe, this is still a case of the nozzle being too close ot the bed.

I’m now using these to store my filament:


I created my own mod of a silica gel container that I now put in the middle of the spool while it’s inside a container.

I just before you posted got on Amazon and I found vacuum bags with a pump to pull out the air for $19.99. I think there were 15 bags.

I was just going to post about a brain #@^& I had.
We know the extruder rate of ? 94.78. I think we have figured out the extruder rate for each head. E1 104.35, and E2 98.99. In my geeetech I have code in each printer management extruders to set nozzle speed of 100% and I remed “;” the default percent which was set at 33, 33,34. Why can we not set in the same printer management our extruder #### we need. That is what we are trying to do with Ponterface. Until JG Maker adds the ability to do this in “permanent” memory.
What is everyone’s thoughts on this.

I have seen the bags before. I’ve also used bags to hold spools. I find the vacuum containers to be a much better solution.

I’m afraid I don’t understand what you’re saying about the extruders

92It worked! I put the extruder value in the folder under printer management and told it to print a file. The file was very acceptable and after the print finished I did a M503 in pronterface and it had the value I set. at the end of the print. I checked before the print and it was the original value.

In Cura on the left you see a tab with the name of the printer – click on this tab, it has a down arrow. Now click on the button that says " Manage Printers", Now you see a new window that lists all your printers in the middle under preset printers. Now to the right you see a button that says “machine settings”,click on this button. Now you see the name of the printer and three tabs, 1) printer, 2) Extrder1, 3) Extruder 2. Select one of the extruders and in the small window that has Extrude start G-code. In this window type a M92 Exxxx. the xx’s represent the value of the extruder stepper motor value. Do the same for the other extruder. Each time you start a single print the m92 E value will set to this value. When you do a multi color print it will switch back and fourth… If you do a duplicate or mirrow I guess it will default to Extrudes 2 because that is the last entered.