No announcement yet.

Running FreeCAD 0.19 on macOS Big Sur

  • Filter
  • Time
  • Show
Clear All
new posts

  • Running FreeCAD 0.19 on macOS Big Sur

    With the release of macOS Big Sur, the FreeCAD pre-releases for version .19 found on the Github release page are not currently working. While there are different ways to install FreeCAD pre-releases on your Mac, I have found that using MiniConda is the easiest way to obtain a working version of .19 with a relatively current revision level.

    Here is a link to the post on the DrVax website that provides step by step instructions for getting FreeCAD .19 working again on macOS Big Sur while the core developers work out the issues with the versions on the Github release page.

    With the release of macOS Big Sur, the FreeCAD pre-releases for version .19 found on the Github release page are not currently working. This post provides a solution.

  • #2

    Thanks for summarizing your MiniConda experience. I followed your steps and ended up with a working version of 0.19 on Big Sur. I initially thought that I might be able to go directly from the initial installation in fcenv to the update instruction you list at the top of the page. But, sadly that didn't do anything, so I went through the step of installing the dev materials. Like your experience, those seemed to hang. Going back and re-executing the steps at the top then updated things such that I now have a current version, as shown below.

    Thanks very much for taking the time to post the instructions!


    OS: macOS 10.16
    Word size of OS: 64-bit
    Word size of FreeCAD: 64-bit
    Version: 0.19.23323 (Git)
    Build type: Release
    Branch: master
    Hash: 512d5c6141aec52b6eecc67370336a28fde862a6
    Python version: 3.8.6
    Qt version: 5.12.5
    Coin version: 4.0.0
    OCC version: 7.4.0
    Locale: English/United States (en_US)
    Last edited by JohnOCFII; 12-19-2020, 10:23 AM.


    • #3
      I've tried following all of your instructions to use miniconda to install Freecad on my Big Sur OS but I can't get to the latest release of it. What have I done wrong? I am hung up on 0.19. Any help would be greatly appreciated. I am a complete noob at this though so please be patient with me!


      • #4
        Thanks for this post. It helped me get me up and running again on Big Sur.

        Thanks very much for the work you put in to do this.



        • #5
          If you're having trouble getting FreeCAD to run on Big Sur you need to make sure you do ALL of the steps in the order listed. This is just a short term fix, but it requires doing the steps in the exact order listed to work.


          • #6
            Hi there, from Holland.
            I just finished installing a Freecad 0.19 version on my Mac! I have tried many things to get the 0.18 version working on my Big Sur Os but without succes.
            I was very glad when I saw your video on YouTube with the link to your excellent explanation! After some tinkering and research I managed to get things running under Miniconda, including a nice Freecad.icns logo in my Automator-app instead of the Automator.icns icon. It all works like a charme. Thank you so much!
            I only have one question left: starting Freecad with the "conda activate fcenv", "freecad" commands works and seems logical.
            But: when and why should I use the "deactivate" command?
            Greetings: Rudy
            Last edited by Rudy Caspers; 01-19-2021, 11:22 AM.


            • #7
              First, to everyone following this thread. If you update FreeCAD with Conda and then it starts hanging again you need to roll back the version of libclang. I updated my post at DrVAX about this to provide more details but the solution to the hanging in Big Sur is to install with Conda and then:

              conda activate fcenv
              conda install libclang=9.0.1

              In terms of deactivating. No need to deactivate unless you want to run something you installed in a different Conda environment. Just close the terminate session. Activating an environment with conda basically makes modifications to the terminal shell environment. When you exit the shell the environment variables go back to the original values.

              You can learn more about this at:

              With the release of macOS Big Sur, the FreeCAD pre-releases for version .19 found on the Github release page are not currently working. This post provides a solution.


              • #8
                Hi Irvshapiro,

                Thanks for your post that I finally installed Freecad 0.19 on my Mac with macOS 11.1.
                However, I've found the same issue as others that I can't update to the latest version by strictly follow your instructions. Only can update to version 21xxxx, still can't use addon manager.

                After some studies I found the reason:
                In your post there are two steps to install Freecad and update to the latest version:
                step 1: % conda update --all
                % conda create --name fcenv --channel conda-forge freecad

                step 2: % conda activate fcenv
                % conda update --all
                % conda config --add channels freecad/label/dev
                % conda update freecad -c=freecad/label/dev

                there is an issue that conda-forge hasn't been added to the channels, which means all the dependents cannot find the right channel to update.

                In your case, I think you already added conda-forge to channels. So you hasn't found this issue.

                I suggest install freecad by this way, which is much easier to install the latest version.

                % conda update --all
                % conda create --name fcenv
                % conda activate fcenv
                % conda config --add channels conda-forge
                % conda install -c freecad/label/dev freecad
                % conda install libclang=9.0.1
                % conda install gitpython
                % freecad

                this is working fine for me.

                Thanks again for your post at DrVAX


                • #9
                  The add-on manager got broken by Microsoft it is not a bug in FreeCAD.

                  Accessing GitHUB files without using the real functionality is kind of a hack. FreeCAD does what a user would do. It accesses the website and downloads the files. The problem is when the website changes this mechanism fails.

                  The FreeCAD devs fixed the changes at one point even in the out dated 0.18 and just a week later Microsoft changed something again and now even the 0.19 is broken.

                  Wasting time in this shit is pointless as you always need to clean the mess behind Microsoft. They should simply host the addon release files somewhere under their control and done. That is the price you pay for not using your own web space.

                  Currently the only way to install Addons in FreeCAD is to download them by hand and install them by hand.


                  • #10
                    Originally posted by Geit View Post
                    Currently the only way to install Addons in FreeCAD is to download them by hand and install them by hand.
                    Sounds like a great topic for a DrV video: How to Manually Download & Install FreeCAD Addons.


                    • #11
                      I wonder if anybody has experience running FreeCAD on a virtual machine on a mac?
                      I have used Oracle virtual box to run linux mint to run Eclipse to do Java programming and it worked fine
                      I am just thinking of options, and would love to ear what others think, or whatever experience could be shared


                      • #12
                        As of now, doing Dr. Vax's conda install method does result in a working .19 build on Big Sur, and addon manager does work for me as well. Make sure to follow those extra steps to update it, and it should work.


                        • #13
                          I was going to hold out for FreeCAD to offer Big Sur support, but I'm starting to think they will never bother to do so. Has anyone seen any motion from FreeCAD on the Big Sur front?


                          • #14
                            The FreeCAD team is currently preparing the official 0.19 release and in bugfixing mode.

                            So it is likely that a proper working Mac version gets released along with the other systems. Latest information is a release date in March, so very soon.


                            • #15
                              And then we can look forward to v0.20 (or whatever they're actually going to call it).