Announcement

Collapse
No announcement yet.

Having trouble after installing BLTouch and new firmware

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Having trouble after installing BLTouch and new firmware

    Hi everybody, greetings from Holland.

    Last month I bought the Ender 3 V2 from Creality. I find manually leveling the bed irritating so iI decided the install the Creality BL Touch.
    I carefully watched the Dr Vax video's severall times ans followed up the instructions.
    The bed was four/five times manually leveled before the first print. The G-code of Creality Slicer 4.2 was adjusted with the code I found on this forum.

    It looks like everything works as expected; but.....
    The prints are damaged and not like the ones I printed before installing the BL Touch.
    I have printed this image several times with the same PLA and the same temperatures (200/60) before installing the BLTouch and they came out wonderfull.

    In the picture you can see the print the way it comes out after installing BL Touch. At the front it looks OK but at the rear it is messy.
    At the bottom of this topic is the G-code I used.

    Can anyone help me to solve this problem ?

    Robert.


    G-code:
    ------------------------------------------------
    ; Start EZABL startup gcode
    M104 S150 ; set extruder temp
    M140 S60 ; set bed temp
    M190 S60 ; wait for bed temp
    M117 Print Starting...
    M75 ; Start Print Timer and Engage Fil Sensor if USB Printing
    M84 E ; Disable E Motor for probe accuracy on direct drive systems
    M117 Antiblob retract...
    G92 E0 ; Reset Extruder distance to 0
    G1 E-2 ; Retracts filament to prevent blobs during probing
    G92 E0 ; Reset Extruder distance to 0
    M117 Homing All...
    G28 ; home all axes
    M117 Homing Z Probe...
    G28 Z ; home z again
    M117 Generating mesh...
    G29; auto bed leveling
    M117 Heaters Recovering...
    G4 S10; wait for heaters to recover
    M420 Z0; Z fade
    M900 K0; LA


    M117 Purging extruder...
    G92 E0 ; reset extruder
    G1 Z1.0 F3000 ; move z up little to prevent scratching of surface
    G1 X0.1 Y20 Z0.3 F5000.0 ; move to start-line position
    M109 S200 ; wait for extruder temp
    G1 X0.1 Y100.0 Z0.3 F500.0 E15 ; draw 1st line
    G1 X0.4 Y100.0 Z0.3 F5000.0 ; move to side a little
    G1 X0.4 Y20 Z0.3 F500.0 E30 ; draw 2nd line
    G92 E0 ; reset extruder
    G1 Z1.0 F3000 ; move z up little to prevent scratching of surface

    M117 Printing.....
    ; End EZABL startup code


    Click image for larger version

Name:	1.jpg
Views:	56
Size:	150.5 KB
ID:	8975
    Click image for larger version

Name:	2.jpg
Views:	453
Size:	201.0 KB
ID:	8974

  • #2
    Not sure where you got that startup code but all you have to do is put a G29 after the G28 and you should be good to go.

    ; Ender 3 Custom Start G-code
    G92 E0 ; Reset Extruder
    G28 ; Home all axes
    G29 ; Auto Bed Leveling

    Thats what the first 4 lines of mine looks like.

    Comment


    • #3
      hmmmm, there is a G29, after the G28 and G28 Z.

      Comment

      Working...
      X