Announcement

Collapse
No announcement yet.

Geeetech A20T

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Geeetech A20T

    About a month ago I got interested in 3D printing an blindly went to Amazon to look at printers. I liked the idea of having more than one filament, large build plate and decedent price. I knew nothing about 3d printing and choose the A20T! Today, a month later I have watched dozens of videos on the subjects and feel I made a great mistake. First by purchasing both PLA and Pteg filaments, and having no knowledge of the difference, only the colors I ordered with the printer. The first thing I did was level the bed. That seemed easy enough, did it cold and thought it was enough. I loaded all three extrudes with.filiment, black in 1. red in 2. and blue in 3. Had PLA in one and the other two had Pteg. I with the luck of the Irish, I guess, found a cell phone stand STL and ran it blindly through Cura, loaded it on the SD cart and got it to start printing. When it finished, it looked weird because it used all three filaments. When I tried to remove it from the plate it crushed into a dozen or so pieces. While it was printing I started searching on internet and watched a couple videos. I was late to find DrVAX videos, but since I feel he is the best source of information. Now when I level the plate, I do it first cold and then again hot (I go through it hot twice.). I am using painters tap, with mostly success, but some not successful removing from plate. Biggest problem warping. I have started using a Brim and two sides are nice and smooth, but the return side is not with what I understand are called bumps and dimples. I am still trying to figure that one out. Adhesion and has strings on that side, but leveling is spot on. Another problem, to go along with that. Tall prints seem to loose adheasion and stick to nozzle. Those are my first questions I would like help with. They may not be the most important, but a starting place. Thanks for any help and advice.

  • #2
    Welcome Lowteck. I had similar experiences to you. I have now settled on using PEI coated spring steel sheets (e.g. https://www.aliexpress.com/item/4000...12607477%22%7D), coating them with Dimafix (https://www.matterhackers.com/store/...en/sk/MR0VKNJY). It's an adhesive from a Spanish university. It's hold is temperature sensitive, the hold increasing as the temperature of the bed goes up.

    Besides basic leveling (BTW, I would skip the cold leveling. IMHO, it's a waste of time), I would print 20x20mm 1-layer squares to ensure the 1st layer is perfect. You can see about the process in this video: https://www.youtube.com/watch?v=RZRY6kunAvs.

    I do not mix PLA and PETG in the same nozzle. Well, basically, I no longer print PLA. Then again, I don't print thing for their looks. If I did, like if I wanted to print shiny, multi-color, and other more unusual filaments, I would then print with PLA, using nozzles dedicated to the purpose. When I did print PLA, I printed with nozzle temperatures around 195C and printbed temps around 60C. With PETG I use 230C nozzle and 70C bed.

    Comment


    • #3
      First, thanks for the fast reply! I would love to get the spring steel sheets or glass for my printer. Its bed size is 250 X 250. Not sure but not 255 on x and y. Hard to find that size. Did buy some bed covers but the wrong size too small. I did order a glass plate from Geeetech and they shipped it China Post. Been 3 weeks now and all I can find out is it billed my Pay Pal account and is in transit. Not even the tracking ## gets me anywhere. I also found out while checking on the status that they are sending the A30T plate which is 260 x 260. Too big! I tried some of the glue stick and all that happened was the nozzle scored the plate. I even tried it for the painters tape. I downloaded a single layer pattern after watching DrVAX video. Haven't tried it yet. Been printing the index card holder, got problems getting Cura correct on that. On E3 it prints great. But on E2 it has problems, thought I found difference but didn't. checked again and waiting to print again to find out. I did print all tje pieces of a chess set, red and black, They both look good but on the red the queen turned lose from the bed and stuck to the nozzle twice. That's when I started using a brim.

      Comment


      • #4
        I used glass for a fair while. My issue was the glue stick worked too well on glass. I broke several panes before giving up on it. Don't confuse Dimafix with any kind of glue stick. They are most definitely not the same.

        Here's a 250x250mm PEI sheet: https://www.aliexpress.com/item/1005...70190166%22%7D.

        irvshapiro 's bed level checker is great, but what I wanted you to see in the video from Hobby Hoarder is the signs that indicate the nozzle is too high, too low, or just right. These signs are now my bible when it comes to verifying my printbed is set up correctly.

        Comment


        • #5
          Had a look at the A20T. 3 extruders into 1 nozzle. Interesting. Some points to consider:
          1. I would not mix filament types, at all. Mix colors if you like, as long as they're the same kind of filament, and that includes ensuring they all print the same at the same temperature. That is not a given, even with the same filament type. PLA from one manufacturer make print best at a different temperature than PLA from another maker. Even different color PLA spools from the same maker may print best at different temps.
            .
          2. you should be able to print a single color using a single extruder. That should help avoid some issues.
            .
          3. have you calibrated all of the extruders? This is a process you can look up on youtube. There are a ton of videos about it. Basically, you need to ensure the extruders are feeding the amount of filament to the hotend that the firmware is expecting. It's a step that's vital to getting your printer dialed in. In your case you have to do it for all 3 extruders.
            .
          4. I think you need to slow down a bit; learn to crawl before you run. There are a number of calibration prints you should do before attempting something real:
            1. temperature tower
            2. retraction tower
            3. bridging tower
            4. XYZ calibration cube
            5. CaliCat
            6. AND, of course, 3D Benchy! You can't say you've 3D printed until you've done at least 1 Benchy.

          Comment


          • #6
            I started to do a temperature tower and started the print and then saw where I needed to have a script installed. The tower did not provide one so I went looking. I have done a XYZ calibration cube and it looked great on E3 (extruder) and before that I did a lot of different cubes that used the E1 and they were terrible. I did finally get a good one. Most had holes on back and on top sometimes. I will have to look up the 3d Benchy to find out what that is. On the plate you sent me the location to order -- I just ordered two. I have an account with them but have not ordered in over 5 years. I ordered streaming devices to setup and resell where I used to live. Not since I moved. By past experience, it will take over a month to get. One of the big reasons I quit ordering from them.
            Now back to the calibration tools. I have some things ordered from Amazon that will be here Saturday, I will do some of them then. My print that took all day was full of strings, and I do have retraction turned on. But some of the settings were not correct. On the index card holder it wanted to put zig-zag pattern on the walls ad I saw the ghosting on finished product. I did another on a different extrudes and it was OK. I thought I had made the changes between the two extrudes but apparently not. I do have a very nice one. This last on did not do any warping, I take it because I did a script to lower the temperature as layers were added. Started at 230 and stopped at 220. That test of scripts did work so now I know how to do the temperature tower script. I am trying to learn, and I appreciate the time you have taken to help me.

            Comment


            • #7
              Remember, when it comes to 3D printing, YouTube is your friend. Check out channels like Teaching Tech, Makers Muse, and CHEP. I would include DrVAX, but you obviously already are aware.

              Your issues with 1 extruder vs another sounds to me like differences in calibration. Now, I'm not saying you need to have the settings exactly the same for all 3 extruders. Manufacturing tolerances may necessitate having slightly different steps/mm for each extruder. You may also have to adjust the bolt that increases/decreases the tension on the filament in each extruder. Main thing: make sure each extruder is extruding the same amount of filament over the same period of time, typically 100mm in 1 min.

              Comment


              • #8
                Woah, you took on three times the trouble (for three times the fun)! To reiterate and add to what Ender5r has posted, I would go through the steps he mentioned for each extruder. Get extruder 1 only laying down great first layers and extruding properly first (don't forget to set your z-offset), giving you great benchies. Once you are happy with how extruder 1 is performing, move to the next extruder. And, so on. Then address any color mixing problems. As Ender5r noted, stick with one type of filament. PLA is more forgiving and I'd start with a quality brand (Hatchbox, Matterhackers Build series). Even with the same brand (Hatchbox) and same color, I have seen differences in bed adhesion.

                Check out TeachingTech's website on printer calibration. There is a lot of useful advice. https://teachingtechyt.github.io/calibration.html#intro

                Also,
                in Cura, go to the Market Place and download the Calibration Shapes plugin. It will help you automate the process of generating temperature towers (and other calibration shapes). The Settings Guide is very helpful as well.

                Lastly, don't forget to post pictures and specific slicer settings. 3D printing is a complex process with many variables so the more details the better.

                Welcome to the hive!

                Cheers

                Comment


                • #9
                  Disaster struck last night. I downloaded a lot of calibration files and one was on bed leveling, only thing it was in gcode. It was for the Ender 3 and not my printer. It played music and set odd temperatures for plate and nozzle. It worked when I overwrote the settings on printer. Bad part was the prime. It did not prime and my nozzle needs two layers of prime before print, I guess because three filaments and one nozzle. Therefore the front two circles did not print. Somewhere either this morning or last night something got messed up in Cura and it would not control the temperature and I could not find the reason. So I uninstalled and reinstalled Cura 4.11 and it straightened out I think. Got an appointment and cannot continue until after to really find out. One trauma after another. Alan, I will check it out if I get back home before the football game tonight. Thanks for your input!

                  Comment


                  • #10
                    As Alan posted, work on 1 extruder at a time. I would NOT print downloaded gcode files, at least not yet. And NEVER print a gcode file intended for another printer. Also, when printing a downloaded gcode file in future, always have your finger on the power button and be prepared to use it.

                    Comment


                    • #11
                      Gcode can overwrite your firmware settings too (looking at you, older versions of Prusa slicer). Only use someone else's gcode if you've examined the source code itself and understand what it is doing, in my opinion. Is your printer automatically setting a temperature different or higher than what you set in Cura?

                      Cheers!

                      Comment


                      • #12
                        First, I god a decent leveling software and used it, it even had a picture of the Geeetech bed. It showed the back right square perfect, the other three with some picks in them but for my level they were decent. The middle circle was awful with the nozzle diging into the painters tape. I figured that the middle was very high. On my way home from an appointment I stopped at Staples and bought a metal ruler and checked as a video had shown and could bairly see light from under. but then again the plate was cold. After the game I will warm the bed up and look again. With the center high I do not know how to correct this unless I remove the plate and put some stress on the middle to see what happens. Then again I bought one of the leveling devices for the printer but when the instructions said I had to flash the firmware, I chickened out. Besides I wanted to learn how to level the bed!

                        Comment


                        • #13
                          First, what software did you use? Knowing what you've done, how you did it, and what the results were helps us help you. And, it can help others who come to this forum.

                          Now, to this specific situation. I'm wondering if, like my new JG Maker Artist D Pro printer, there is a post under the center of the bed. If the printbed is fairly large (say 12" square) it could well have such a support post. If that is the case, then you method of leveling will have to change somewhat. Please check that out.

                          Also, flash firmware on many printers these days is quite simple, and this includes the A20T. It's simply a matter of downloading the new firmware, copying it to an empty, formatted SD card, ensuring the A20T is off, insert the SD card, turn the printer back on and wait while the new firmware is flashed to the firmware.

                          Comment


                          • #14
                            What's the print bed--a removable metal plate? I've read about some printers with concave sprint surfaces that were fixed by placing a disk if aluminum foil in the middle under the removable plate. Perhaps, aluminum strategically shaped and placed in the corners could be used to counteract the domed center region. Alternatively, you could contact the manufacturer for a replacement heatbed. (Pictures are worth a thousand words!)

                            In addition to what Ender5r said, some printers flash new firmware by "printing" the .bin firmware file from the SD card.

                            I think you are on the right track by sticking to fundamentals and tramming the printer.

                            Cheers!

                            Comment


                            • #15
                              Ender5r I am not sure what you are asking in the question about software. I use Cura as slicer, it and another software slicer was furnished by the manufacturer. The gcode file came off Thingiverser, not sure of the file number. Also the file I used that gave me a high in middle results also came from there. One of the plugins I downloaded for Cura was a list of test files. I have used all three extrudes to run tests, none have been used on all three extrudes. After I was successful in printing a phone cradle for myself and my mom who had complained about loosing her phones protection with a flip out to tilt her phone, I started printing a file for a chess set using E1 (black) it printed treatable,n so I started printing some of the cubes. I finally got that stable so I wanted to print a classic chess set, I decided that the first which was a resonance set was not thay clean and the classic was. Now here is the rest of the story - The red was on E2 and I knew of no way to address it. Even on Geeetech's forum peopld were asking how to address the E2. In the firmware you could only switch 100% was to do a swap between E1 and E3.. So, I pulled the Teflon tubes out of the hotend and swapped. Stupid I know but remember less than two weeks of knowledge. I had a fit getting the red to work properly, but I figured that one out. The tube was put as far as I could push it but it was not far enough. So I heated the hotend as hot as I dared (240). Then I used one of the tools provided and pushed the hot filament, the Teflon tube was not in for the red and E3. I pushed a lot of filiment through the nozzle and it was enough to insert the tube into the hotend enough to make it work properly. I now do not have a problem with E3. On E2, I have stringing a lot and I see temp drop when it does start extruding.
                              I think that since there is not a fix just now for a high center on the build plate I will clean out the tube for E2 and see if it fixes E2 stringing problem. I do have a glass plate ordered from a slow boat from china. I also have some plates that was pointed out in an earlier post by Ender5r
                              Last edited by Lowteck; 09-18-2021, 12:18 PM.

                              Comment

                              Working...
                              X